Advertisements
Home > CRM 2011, Upgrade > Sitemap “Settings groups” display as “Unknown” after an upgrade from CRM 4.0 to CRM 2011

Sitemap “Settings groups” display as “Unknown” after an upgrade from CRM 4.0 to CRM 2011

Sitemap Upgrade Errors

Hi,

Recently when i did an upgrade from CRM 4.0 to CRM 2011 by restoring CRM 4.0 DB, I got “Settings groups” display as “Unknown” (Refer image above)

– To fix this issue we have to modify the “Sitemap” by exporting it in a solution, and follow below steps

  • Open the “customizations.xml” file in text editor by extracting the solution zip folder
  • Replace <Group Id=”Business_Setting”> with <Group Id=”Business_Setting” ResourceId=”Menu_Label_Business” DescriptionResourceId=”Menu_Label_Business”>
  • Replace <Group Id=”System_Setting”> with <Group Id=”System_Setting” ResourceId=”Menu_Label_System” DescriptionResourceId=”Menu_Label_System”>
  • Replace <Group Id=”Customizations”> with <Group Id=”Customizations” ResourceId=”Homepage_SystemCustomization” DescriptionResourceId=”Homepage_SystemCustomization”>
  • Replace <Group Id=”ProcessCenter”> with <Group Id=”ProcessCenter” ResourceId=”Menu_Label_ProcessCenter”
    DescriptionResourceId=”Menu_Label_ProcessCenter”>
  • Import the solution and publish

– Please refer http://support.microsoft.com/kb/2530358 for more details.

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: